- - - By CrazyStat - - -

CMSimple_XH (1.7.X) Dokumentation



(Version 1.0.8 vom 04.04.2018)

Sie sind hier: Jquery

3.1.5.3 jquery

Unter "Plugins" => "Jquery" kann eine kleine Startoberfläche der freien und umfangreichen JavaScript-Bibliothek aufgerufen werden, von der CMSimple_XH einige Funktionalitäten nutzt.
Von dieser Startseite des Plugins Jquery haben Entwickler und Webmaster die Möglichkeit die Systemparameter unter "Konfiguration" zu ändern.

Jquery – Konfiguration

VERSION  
• Core 1.12.4
Ui 1.1e.1
Migrate jquery-migrate-1.4.1.min.js
LOAD  
• Migrate Soll das Migrate-Plugin geladen werden?
Default Einstellung: aktiviert.
AUTOLOAD  
• Autoload Sollen die JS Bibliotheken automatisch auf allen Seiten geladen werden?
Default Einstellung: deaktiviert
Libraries Soll nur jQuery, oder jQuery zusammen mit jQueryUI automatisch geladen werden?
Default Einstellung: jQuery

 Jquery – Sprach-Datei

CF  
• Autoload Sollen die JS Bibliotheken automatisch auf allen Seiten geladen werden?
Autoload libraries Soll nur jQuery, oder jQuery zusammen mit jQueryUI automatisch geladen werden?
• Load migrate Soll das Migrate-Plugin geladen werden?.
UTF-8-MARKER  
• Utf-8-marker äöü

In allen Versionen wird im Menüpunkt "Hilfe" eine separate Hilfeseite vom Entwickler des Plugins für Entwickler und Webmaster angezeigt.

Hinweis zur Konfiguration von jQuery:
Ein bedeutender Unterschied zwischen den jQuery Hauptversionen ist die Unterstützung älterer IE Browser Versionen (jQuery 1.x unterstützt IE 6+, jQuery 2.x und 3.x unterstützen IE 9+).
Da jQuery 3 die am besten gepflegte Version sein dürfte, bietet sie sich "auf den ersten Blick" als die bevorzugte jQuery Version (unter Umständen in Kombination mit dem Migrate-Plugin) an.

Bei der Versionswahl des jQuery sollten folgende Aspekte berücksichtigt werden:

  • Auf der Website eingesetzte jQuery-Plugins harmonisieren unter Umständen nur mit einer bestimmten jQuery Version (Abhängigkeiten sind evtl. in der Doku vermerkt, bzw. es muss ausprobiert werden mit welcher jQuery Version das Plugin funktioniert.) Zur Minimierung von Inkompabilitäten (jQuery / Plugins) wurde das (ressourcenschonende) Migrate-Plugin entwickelt, welches bei Bedarf aktiviert werden kann.
  • Bei seinem Einsatz müssen die Hauptversion von jQuery und Migrate-Plugin übereinstimmen (also beispielsweise jQuery 1.12.4 mit Migrate 1.4.1, oder jQuery 3.2.1 mit Migrate 3.0.0)